Plesk Login Service Disruption
Incident Updates
-
Resolved 9 hours ago · Sep 21, 2026 12:55 UTC
Our technicians have confirmed that the Plesk Control Panel issue has now been resolved. We want to thank our clients for the patience they've had whilst our team was working on this resolution and apologise again for any of the inconveniences caused. If you have further issues please don't hesitate to reach out to us.
-
Investigating 15 hours ago · Sep 21, 2026 07:09 UTC
We would like to keep you updated with a notice that the infrastructure team is still working on this issue. A few more servers have been affected - they can be confirmed below: celeste.cirrushosting.com halo.cirrushosting.com mooch.cirrushosting.com myst.cirrushosting.com sonic.cirrushosting.com Our team is still actively investigating the cause and working to restore access as quickly as possible. We will provide another update as soon as more information becomes available.
-
Investigating 1 day ago · Sep 20, 2026 06:58 UTC
We would like to keep you updated with a notice that the infrastructure team is still working on this issue. We will update this status page as soon as we are able to.
-
Investigating 2 days ago · Sep 19, 2026 01:31 UTC
We are currently investigating an issue affecting access to the Plesk control panel on the following servers: sonic.cirrushosting.com mooch.cirrushosting.com Our team is actively investigating the cause and working to restore access as quickly as possible. We will provide another update as soon as more information becomes available.